MOCpages : Share your LEGO® creations
LEGO models my own creation MOCpages toys shop MOCpages help
Welcome to the world's greatest LEGO fan community!
Explore cool creations, share your own, and have lots of fun together.  ~  It's all free!
Conversation »
How to add videos
Join to comment
I do not know how to add a video to Mocpages. It is on youtube but I cannot get it on to a page.
Permalink
| January 1, 2011, 2:43 pm
Quoting Andrew Morley
I do not know how to add a video to Mocpages. It is on youtube but I cannot get it on to a page.

You have to have the embed code. It should be in a button under the description. Some people disable that code. Hope that helps!
Permalink
| January 1, 2011, 2:47 pm
Quoting Matthew Novosad
You have to have the embed code. It should be in a button under the description. Some people disable that code. Hope that helps!

I copied that code and pasted it to the box where the photo html usually goes, but when I previewed the page nothing showed up.
Permalink
| January 1, 2011, 4:17 pm
Quoting Andrew Morley
I copied that code and pasted it to the box where the photo html usually goes, but when I previewed the page nothing showed up.

Are you sure you copied the code properly? Can you paste the code here?
Permalink
| January 1, 2011, 4:42 pm
Ok, i got it. Turns out it wasn't showing up on the preview page but when I created the page anyway it showed up.
Permalink
| January 1, 2011, 11:28 pm
well im still not getting it and how do you add music in very easy term
Permalink
| January 1, 2011, 11:55 pm
How do I add the YouTube video on one of my creation pages? I don't know how, so can you help me how?
Permalink
| March 13, 2011, 2:50 pm
Quoting Rahkshi Poopi
How do I add the YouTube video on one of my creation pages? I don't know how, so can you help me how?

You need to copy and paste the embed code. But first, you needs to make sure that it's the old version, not the new one. Also, you'll problably need to shrink the size to 400 (width) 282 (height). I hope this will help you.
Permalink
| March 13, 2011, 11:47 pm
I also have a problem uploading videos but when I copy the embeded link it says I cannot use Iframes

Permalink
| August 21, 2012, 9:10 am
Quoting xXxKILLSHOTxXx :D
I also have a problem uploading videos but when I copy the embeded link it says I cannot use Iframes

Use the old embed code. Isn't this on the frequently asked questions page? When we people figure it out? -.-
Permalink
| August 21, 2012, 10:05 am
Quoting MCLegoboy !
Use the old embed code. Isn't this on the frequently asked questions page? When we people figure it out? -.-

I don't exactly know how to use the embed code. Can you give me a tutorial or something?
Permalink
| March 29, 2015, 12:57 am
Quoting Griffin .
I don't exactly know how to use the embed code. Can you give me a tutorial or something?

Alright, this is copied from a past topic. iframes no longer work, and YouTube no longer offeres the old embed code, but, since I have spammed this website with my MOC reviews from YouTube, I happen to still have the old embed code. Now, this may get a bit complicated, but I hope you will be able to follow it.

I've figured it out. Here is the old embed code:

Quoting
<object width="500" height="281"><param name="movie" value="http://www.youtube.com/v/ABCDEFGHIJK?version=3&hl=en_US"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/ABCDEGHIJK?version=3&hl=en_US";; type="application/x-shockwave-flash" width="500" height="281" allowscriptaccess="always" allowfullscreen="true"></embed></object>


Now, to fix this, you just take the number and letter part of the YouTube URL after v= (I have replaced this with ABCDEFGHIJK in the example below and also in the embed code above.) and replace it with the one of the video you want in there.




It is 11 characters long, and it appears twice in the embed code inbetween
Quoting

/v/ and ?

You need to remove that area and replace it with the new one.
Permalink
| March 29, 2015, 5:28 am
Quoting MCLegoboy !

Thank you so much, this worked perfectly.
Permalink
| March 29, 2015, 10:21 am
I'd like to point out two things.
-It's considered rude to post in a thread that hasn't seen a new post for more than a week or two.
-It's considered extremely rude to set embedded youtube clips to autoplay, since that sets off a mad hunt for the single tab among a dozen that's playing strange music without permission.

Permalink
| March 29, 2015, 11:46 am
Quoting Areetsa C
I'd like to point out two things.
-It's considered rude to post in a thread that hasn't seen a new post for more than a week or two.
-It's considered extremely rude to set embedded youtube clips to autoplay, since that sets off a mad hunt for the single tab among a dozen that's playing strange music without permission.

1. It's called Recycling. Why do we need another topic where there have been three in the last month for video stuff?
2. The embed code that I gave is not set for autoplay.
Permalink
| March 30, 2015, 8:48 am
Okay, so.

I've tried using the current embed code, tells me not to use iframe.

Tried using the embed code that MCLegoboy has provided, tells me not to use applets.

Any other ways I can use to embed?
Permalink
| April 11, 2015, 1:11 pm
 Group moderator 
Brfore going any further please read the site rules before adding videos. I don't want to nag, but you aren't really supposed to add them unless they are lego related anyway.
Permalink
| April 11, 2015, 1:29 pm
Quoting andros tempest
Brfore going any further please read the site rules before adding videos. I don't want to nag, but you aren't really supposed to add them unless they are lego related anyway.

And yet many people post music on their pages anyway? :/
Permalink
| April 11, 2015, 1:31 pm
Quoting Commander Spencer
And yet many people post music on their pages anyway? :/
Yep... Don't know why, but they probably just can.
Permalink
| April 11, 2015, 6:06 pm
Quoting Commander Spencer
Okay, so.

I've tried using the current embed code, tells me not to use iframe.

Tried using the embed code that MCLegoboy has provided, tells me not to use applets.

Any other ways I can use to embed?

The old embed code didn't come with applets! What? I've used it before, and it works fine.

You guys need to stop going all high-tech and go back to using the AOL Browser. Never had a problem uploading anything to MOCpages with it.
Permalink
| April 11, 2015, 6:28 pm
Quoting Commander Spencer
Any other ways I can use to embed?

Assuming the video shows a LEGO model, which is just about the only allowable use of a video on here, see if any of the following information helps. It's a bit detailed, but it explains why embed codes sometimes don't work, how to generate valid embed codes using either iframe or the old embed code, both of which continue to work just fine when used properly, and if all else fails it has examples you can copy.
http://equinoxe.byethost16.com/lego/mocpages/youtube/

Permalink
| April 12, 2015, 5:52 am
Other topics
Report non-Lego thread 16 Updated yesterday
Pages dissapearing??? Updated yesterday
Cannot Upload Imagaes Updated Sunday
student teen kid toy play lego child video game hobby blocks construction toy legos fun games



LEGO models my own creation MOCpages toys shop MOCpages help


You Your home page | LEGO creations | Favorite builders
Activity Activity | Comments | Creations
Explore Explore | Recent | Groups
MOCpages is an unofficial, fan-created website. LEGO® and the brick configuration are property of The LEGO Group, which does not sponsor, own, or endorse this site.
©2002-2015 Sean Kenney Design Inc | Privacy policy | Terms of use